MySQL中间件 Atlas-1.0.3 安装记录

1、wget https://github.com/Qihoo360/Atlas/archive/1.0.3.tar.gz -o Atlas-1.0.3.tar.gz

2、tar zxvf Atlas-1.0.3.tar.gz

3、cd Atlas-1.0.3

4、vim bootstrap.sh

#!/bin/sh
base=$(cd “$(dirname “$0″)”; pwd)
cd $base
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig ./configure –with-mysql=/opt/phpdba/mysql/bin/mysql_config –prefix=/opt/phpdba/atlas_mysql_proxy CFLAGS=”-DHAVE_LUA_H -O2″ LDFLAGS=”-lm -ldl -lcrypto” LUA_CFLAGS=”-I/usr/local/include/” LUA_LIBS=”-L/usr/local/lib -llua”

5、./bootstrap.sh glib版本低,升级之

checking for GLIB… configure: error: Package requirements (glib-2.0 >= 2.32.0) were not met:

Requested ‘glib-2.0 >= 2.32.0’ but version of GLib is 2.22.5

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

6、升级glib

a、wget http://ftp.gnome.org/pub/gnome/sources/glib/2.36/glib-2.36.3.tar.xz

b、xz -d glib-2.36.3.tar.xz && tar xvf glib-2.36.3.tar

c、cd glib-2.36.3 &&  ./configure && make

保存信息:

/root/chen-123/glib-2.36.3/missing: line 81: automake-1.13: command not found
WARNING: ‘automake-1.13’ is missing on your system.
You should only need it if you modified ‘Makefile.am’ or
‘configure.ac’ or m4 files included by ‘configure.ac’.
The ‘automake’ program is part of the GNU Automake package:
<http://www.gnu.org/software/automake>
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
<http://www.gnu.org/software/autoconf>
<http://www.gnu.org/software/m4/>
<http://www.perl.org/>
make[4]: *** [Makefile.in] 错误 127
make[4]: Leaving directory `/root/chen-123/glib-2.36.3/docs/reference/glib’
make[3]: *** [all-recursive] 错误 1
make[3]: Leaving directory `/root/chen-123/glib-2.36.3/docs/reference’
make[2]: *** [all-recursive] 错误 1
make[2]: Leaving directory `/root/chen-123/glib-2.36.3/docs’
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/root/chen-123/glib-2.36.3′
make: *** [all] 错误 2

d、wget http://ftp.gnu.org/gnu/automake/automake-1.13.3.tar.gz  &&  tar zxvf  automake-1.13.3.tar.gz  && cd automake-1.13.3 &&  ./configure

错误信息:

checking whether autoconf is recent enough… no
configure: error: Autoconf 2.65 or better is required.

e、wget ftp://ftp.gnu.org/gnu/autoconf/autoconf-2.69.tar.gz && tar zxvf  autoconf-2.69.tar.gz && cd autoconf-2.69 && ./configure && make && make install

f、cd automake-1.13.3 && ./configure && make   &&make install

g、cd glib-2.36.3 &&  ./configure && make

报错:

configure.ac:66: error: version mismatch.  This is Automake 1.13.3,
configure.ac:66: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:66: comes from Automake 1.13.2.  You should recreate
configure.ac:66: aclocal.m4 with aclocal and run automake again.
gtk-doc.make:32: warning: EXTRA_DIST multiply defined in condition TRUE …
docs/reference/glib/Makefile.am:85:   ‘gtk-doc.make’ included from here
Makefile.decl:8: … ‘EXTRA_DIST’ previously defined here
docs/reference/glib/Makefile.am:2:   ‘Makefile.decl’ included from here
WARNING: ‘automake-1.13’ is probably too old.

h、cd automake-1.13.3 &&  make uninstall  && wget http://ftp.gnu.org/gnu/automake/automake-1.13.2.tar.gz  &&  tar zxvf  automake-1.13.2.tar.gz  && cd automake-1.13.2 &&  ./configure && make && make install

i、cd glib-2.36.3 &&  ./configure && make && make install

7、cd Atlas-1.0.3  &&  ./bootstrap.sh && make && make install    安装完成

此条目发表在技术生涯分类目录,贴了, , 标签。将固定链接加入收藏夹。

发表评论

邮箱地址不会被公开。 必填项已用*标注